【Linux】Redis 离线安装
1062 字
5 分钟
【Linux】Redis 离线安装
下载并解压Redis
执行下面的命令下载redis:
wget https://download.redis.io/releases/redis-6.2.6.tar.gz
解压redis:
Terminal window tar xzf redis-6.2.6.tar.gz
移动redis目录,一般都会将redis目录放置到 /usr/local/redis目录:
Terminal window mv redis-6.2.6 /usr/local/redis
编译并安装redis
进入redis安装目录,执行make命令编译redis:
Terminal window cd /usr/local/redismake等待make命令执行完成即可。
如果执行make命令报错:cc 未找到命令,原因是虚拟机系统中缺少gcc,执行下面命令安装gcc:
Terminal window yum -y install gcc automake autoconf libtool make如果执行make命令报错:致命错误
/jemalloc.h: 没有那个文件或目录,则需要在make指定分配器为libc。执行下面命令即可正常编译: Terminal window make MALLOC=libcmake命令执行完,redis就编译完成了。
执行下面命令安装redis,并指定安装目录
Terminal window make install PREFIX=/usr/local/redisimage-20240617144514525 至此,redis即安装成功。
启动redis
进入redis安装目录,执行下面命令启动redis服务
Terminal window # 启动./bin/redis-server redis.conf# 关闭./bin/redis-cli shutdown此时,可以看到redis服务被成功启动:
image-20240617144725136 但这种启动方式不能退出控制台,如果退出,那么redis服务也会停止。如果想要redis以后台方式运行,需要修改redis的配置文件:
redis.conf。将该配置文件中的daemonize no改为daemonize yes即可:修改完成后,重新执行启动命令启动redis,然后通过下面命令查看redis进程,可以发现redis服务已经被启动了:
Terminal window ps -ef | grep redis
其他设置
daemonize:如需要在后台运行,把该项的值改为yes
pdifile:把pid文件放在/var/run/redis.pid,可以配置到其他地址
bind:指定redis只接收来自该IP的请求,如果不设置,那么将处理所有请求,在生产环节中最好设置该项
(设置0.0.0.0 则改为用iptables来控制访问权限)
port:监听端口,默认为6379
timeout:设置客户端连接时的超时时间,单位为秒
loglevel:等级分为4级,debug,revbose,notice和warning。生产环境下一般开启notice
logfile:配置log文件地址,默认使用标准输出,即打印在命令行终端的端口上
database:设置数据库的个数,默认使用的数据库是0
save:设置redis进行数据库镜像的频率
rdbcompression:在进行镜像备份时,是否进行压缩
dbfilename:镜像备份文件的文件名
dir:数据库镜像备份的文件放置的路径
slaveof:设置该数据库为其他数据库的从数据库
masterauth:当主数据库连接需要密码验证时,在这里设定
requirepass:设置客户端连接后进行任何其他指定前需要使用的密码
maxclients:限制同时连接的客户端数量
maxmemory:设置redis能够使用的最大内存
appendonly:开启appendonly模式后,redis会把每一次所接收到的写操作都追加到appendonly.aof文件中,当redis重新启动时,会从该文件恢复出之前的状态
appendfsync:设置appendonly.aof文件进行同步的频率
vm_enabled:是否开启虚拟内存支持
vm_swap_file:设置虚拟内存的交换文件的路径
vm_max_momery:设置开启虚拟内存后,redis将使用的最大物理内存的大小,默认为0
vm_page_size:设置虚拟内存页的大小
vm_pages:设置交换文件的总的page数量
vm_max_thrrads:设置vm IO同时使用的线程数量通过redis-cli测试redis是否可用,在redis安装目录执行下面命令:
Terminal window ./bin/redis-cliimage-20240617144907738
此处我们通过下面命令随便set一个字符串类型的值,key是test,value是hello:
Terminal window set test helloimage-20240617145110416
然后通过下面命令get出test这个key的value值:
Terminal window get testimage-20240617145127840
测试没有问题,至此,redis在我们的Linux服务器上就已经安装完成了。
开机自启
Terminal window vim /usr/lib/systemd/system/redis.service
注意:—daemonize no 为必须的,要不然起不来
Terminal window [Unit]Description = Redis ServerAfter = network.target[Service]ExecStart = /usr/local/redis/bin/redis-server /usr/local/redis/etc/redis.conf --daemonize noExecStop = /usr/local/redis/bin/redis-cli -p 6379 shutdownRestart = always[Install]WantedBy = multi-user.target
Terminal window # 重新加载服务systemctl daemon-reload# 开机自动启动systemctl enable redis.service# 取消开机自动启动(卸载服务)systemctl disabled redis.service# 启动redis服务systemctl start redis.service# 查看服务状态systemctl status redis.service# 停止服务systemctl stop redis.service
支持与分享
如果这篇文章对你有帮助,欢迎分享给更多人或打赏支持!
相关文章智能推荐
1
【Linux】Doris 安装部署
Linux在Linux环境下Doris和StarRocks的安装部署流程。首先,文档涵盖了环境配置,包括服务器环境、Docker的安装与卸载步骤,重点描述了Doris的编译安装过程,以及StarRocks的部署准备、环境配置、服务启动等步骤,提供了如何通过MySQL客户端访问FE、添加BE与Broker实例到集群的具体操作方法
2
【Linux】nginx 离线安装
Linux本文《【Linux】nginx 离线安装》详细介绍了在Linux环境下离线安装Nginx的全过程。文章详细描述了Nginx的编译安装过程,并提供了启动Nginx的常用命令。最后,文章介绍了如何配置Nginx的开机自启动,确保服务在系统重启后能够自动运行。这些内容对离线环境下的Nginx安装和管理非常有帮助。
3
【Linux】Libgdiplus安装
Linux在CentOS 7上安装libgdiplus的过程,以解决ASP.NET Core MVC项目在处理图片时遇到的The type initializer for ‘Gdip‘ threw an exception错误。首先,通过安装yum-utils和epel-release来获取必要的工具和仓库支持。
4
【Linux】安装OpenJDK
Linux本文详细介绍了在Linux系统上安装OpenJDK的方法,包括在线安装和离线安装两种方式。在线安装部分,首先检查系统中是否已存在Java环境,然后使用yum命令安装OpenJDK,并配置环境变量。离线安装部分,适用于无外网的集群环境,需预先下载OpenJDK二进制包,上传至指定目录,解压并配置环境变量。
5
【Linux】Nacos 问题
Linux本文《【Linux】Nacos 问题》详细记录了在Linux环境下遇到的Nacos服务连接问题及其解决方法。文章还介绍了如何配置Nacos服务的开机自启动,确保服务在系统重启后能够自动运行。这些内容对解决Nacos连接问题和提高系统稳定性非常有帮助。
随机文章随机推荐
小王的博客



















